MaxScore for Max/MSP and Ableton Live

Music Notation for Max/MSP and
Ableton Live

About MaxScore

MaxScore provides standard western music notation in Max/MSP and Ableton Live via Max for Live.

MaxScore is a Max object which accepts messages that can create a musical score, add notes to it, transform the notes, perform, save, and load the score, and export the score to popular formats for professional publishable results.

MaxScore is more than a notation tool. It is an interactive performance object. MaxScore can play back a score and drive your MSP patches through an instrument interface. Scores can be created and modified in real-time. You can add notes explicitly by specifying durations and pitches, or use Max to generate an arbitrary stream of musical events and use MaxScore’s Transcriber to notate them automatically.

MaxScore currently exports to MusicXML so you can load your scores into Finale and Sibelius. MaxScore also exports to the GNU LilyPond automated engraving system. In addition, the MaxScore / LiveScore Editors will allow you to create a pdf of your scores directly from the notation environment. The Editor also offers XML import for scores created with other applications.

MaxScore was programmed in Java Music Specification Language by Nick Didkovsky (but requires no Java programming to operate). MaxScore was commissioned by “Bipolar – German-Hungarian Cultural Projects.” Bipolar is an initiative of the Federal Cultural Foundation of Germany. While MaxScore is freely available to the public, it requires purchasing a JMSL license to run (see below).

Read what users have to say about their experience with MaxScore.
MaxScore for Max/MSP and Ableton Live

News

August 22, 2012

MaxScore 0.4 released

January 6, 2012

Implementation of Just Intonation with the Helmholtz-Ellis notation is currently in alpha stage. Thanks to Marc Sabat for his help by providing his Helmholtz-Ellis calculator. This is an example of the 43-tone Partch scale:

January 5, 2012

Happy New Year everybody!

Composer Arne Eigenfeldt, Associate Professor of Music and Technology at Simon Fraser University is sending us these lines. Thanks, Arne!

MaxScore has changed the way I work with Max (which I've been using since 1991). Since I'm trained as a
composer, I feel most comfortable when I can see my music represented symbolically, and MaxScore allows for that seamlessly. My research into generative systems incorporating genetic algorithms, multiagent systems, and ALife approaches now find their “voice” in notated music. In December 2011, my research group presented a concert of Musical Metacreation (computationally creative systems that produce music that should be indistinguishable from human-composed), in which MaxScore was indispensable. My software generated compositions (using a multi-stage genetic algorithm) that were sent to MaxScore, and the data saved as MusicXML files, which were imported into Finale and performed by musicians. (I’ve included an example finished score for solo percussionist) Our next project (May 2012) will involve live score generation for an ensemble. Naturally, none of this was possible without MaxScore – thanks, guys!

December 29, 2011

I hope you all had wonderful holidays. Depending on your user profile, we will soon offer two license types for MaxScore. In the meantime, I was alerted by one of our beta testers, that, in Max 6 on Mac OS X, there is an offset issue with our default font (Aloisen New). Use this fix if you prefer to work in Max 6 on Mac OS X. The installer will only install 2 files despite its size and appearance!!

BTW, Nick just tells me that “JMSL’s Lilypond exporter will now attach text to intervals in chords. Thanks to David Kant for doing the Lilypond research and sending me the appropriate macro defs. He uses it to display cent offsets next to noteheads in chords.” This feature will available in a future release.

Happy New Year 2012!

December 10, 2011

Most kinks have been straightened out and MaxScore 0.3 is pretty much complete now.

The new features are:

- New music editor for Max and Max for Live with a large set of features
- Microtonal notation up to 72TET with variable sets of accidentals
- Microtonal, polyphonic and multi-timbral playback with sampler and soundfont player for Max and Max for Live.
- Graphics editor for the design of an unlimited number of symbols and graphics

November 29, 2011

MaxScore 0.3 is nearing completion and the first betas have been posted. See Downloads page.

This version will be particularly interesting to microtonal composers as it provides microtonal notation (with up to 72TET resolution) and playback with unlimited precision. It also includes a microtonal, polyphonic and polytimbral sampler for microtonal playback, freeing the users from the outdated and cumbersome MIDI pitch bend specification. There is already a grand piano sound bank available for download. Further sound banks will be posted as development continues.

There are also some changes what the naming the Max for Live components is concerned: MaxScore for Live is
now called *LiveScore* (much more catchy, don’t you think so?). Hence, *MaxScore for Live* - *MasterScore* is now *LiveScore Editor* while *MaxScore for Live* - *ClipView* has been renamed to *LiveScore Viewer*.

November 05, 2011

The new MaxScore version is taking us a bit longer than expected. In the meantime Max 6 was just released and people are wondering how to copy their MaxScore files to Max 6.

Just follow these instructions:

Copy items:

- `/Applications/Max5/Cycling '74/MaxScore Lib and`  
  `/Applications/Max5/Cycling '74/Docs into /Applications/Max6/Cycling '74/`
- `maxscore.jar, jscore.jar jmsl.jar, punosmusic.jar and NN.jar from /Applications/Max5/Cycling '74/java/lib/`  
  into `/Applications/Max6/Cycling '74/java/lib/`
- `/Applications/Max5/Cycling '74/java/classes/nnlists.class into /Applications/Max6/Cycling '74/java/classes/`
- `/Applications/Max5/Cycling '74/init/maxscore-objectlist.txt into /Applications/Max6/Cycling '74/init`
- `/Applications/Max5/patches/extras/MaxScore into /Applications/Max6/patches/extras/
- `/Applications/Max5/patches/templates/maxscore.maxpat into /Applications/Max6/patches/templates`
- `/Applications/Max5/patches/object-prototypes/bpatcher/bcanvas.maxproto`  
  and `/Applications/Max5/patches/object-prototypes/bpatcher/btoggle.maxproto`  
  into `/Applications/Max6/patches/object-prototypes/bpatcher/`

The expected release date (the wait is worthwhile!!) is sometime in December.

July 28, 2011

This is a preview of the upcoming graphics editor for MaxScore for Live. The editor will enable users to create extra articulations and expressions and store them in a library. They can be attached to notes, staves and/or measures and edited as groups. There are 14 basic shapes/elements to choose from which all can be colored and made transparent. Pictures can be resized and cropped. Graphics can also be exported as svg files.

We are expecting to be done by mid-August.
May 20, 2011

Version 0.2 is ready to ship. We have added an open plugin system called Scorepions which will allow users to use standard Max patches to greatly extend the functionality of MaxScore for Live. In addition, MaxScore now supports a number of music fonts (Aloisen New, Jazz, Maestro, Opus) and the text fonts installed on your machine.

On the Downloads page you will already find links to the installers. Give us feedback whether everything works as expected.

Starting with version 0.2 we will also switch to a cross-platform installer which will greatly speed up the deployment of new builds.

Version 0.3 is already on the horizon. It will feature a full-blown graphics editor permitting the creation of custom elements and graphics, either attached to notes, measure/staves or measures, or saved as global library elements ready to be reused at any time.
Download

Installation

Installation involves two steps:

1. Download and installation of MaxScore/LiveScore
2. Authorization of MaxScore/LiveScore

Caveat: You need to ABSOLUTELY make sure you that you have matching versions when using MaxScore/LiveScore with Ableton Live. If you have installed MaxScore into the Max 6 folder, Max 6 will also need to be selected as Max application in the File/Folder pane of the Ableton Live preferences. The same applies to Max 5. Otherwise your installation may not work (unless you have installations for both versions of Max).

1. Download and installation of MaxScore/LiveScore

Get the installers for:

Version 0.4.9 (posted on January 8, 2013)

- [Mac OS X](#)
- [Windows](#)

- Mac OS X 10.5 or higher; Java 1.5; Max 5.1.9 or higher
- Windows XP or higher; Java 1.5; Max 5.1.9 or higher
- LiveScore users will need Ableton Live 8.2.2 or higher in addition (LiveScore has not been tested in Live 9 yet; running it in 64-bit mode will most certainly NOT work)

Please follow these instructions on how to install MaxScore.

After downloading the installer, open the file. You will first see a splash screen with a blue scorpion and a text window informing you about the steps you’re about to take:
Click OK and click the Next button in the installer window underneath;

Accept the license agreement and click on Next:
Now, navigate to the location of the Max folder you wish to install MaxScore to:

Make sure this folder contains a valid Max application. Otherwise you may run into problems later on. Possible targets are: Max 5, Max 5 Runtime, Max 6 and Max 6 Runtime.

After clicking Next, decide on the type of installation (Minimal = Maxscore for Max only; Full = MaxScore and LiveScore for Ableton Live).
If you choose Minimal, the installer show the Ready to Install page and will start copying its files to the Max folder as well as open a browser window allowing you to apply for a free 30-day JMSL license. Don’t apply for a license if you already have a one, expired or not. If your license has already expired, you can either purchase a permanent license or request an extension of your trial license from algomusic.com.

If you choose Full, the installer will lead you to yet another page that will let you specify the location of the Ableton Live Library folder. This is a crucial step! Refer to http://www.computermusicnotation.com/?page_id=659 to determine the location of this folder.

The installer is now ready to begin to install MaxScore on your computer:
Once you're done copying the files to the Max folder, a browser window will open allowing you to apply for a free 30-day license for JMSL. Don’t apply for a license if you already have a one, expired or not. If your license has already expired, you can either purchase a permanent license or request an extension of your trial license from algomusic.com.

2. Authorization of MaxScore

You’ll need to authorize MaxScore once you’re done with the installation process. For this, use your old JMSL license or request a new license from www.algomusic.com (the Mac OS X installer will take you there at the end of the installation). Once you’ve received your license, locate the JMSL License Installer and drag the .lic file onto the License Installer.

There is no need to install additional software such as the current JMSL release!!

Once you’re done either open Max and choose maxscore or maxscore.combo from the Max File->New From Template menu or open the set LiveScore Demo.als in Ableton Live.

3. Sounds

The MaxScore/LiveScore Fluidsynth and Sampler components require sounds to be downloaded for playback. This page will help you to get you started.
LiveScore

LiveScore is a visual notation environment for Live based on MaxScore. It is thoroughly integrated into Live via the API provided by Max/MSP and allows the transcription and editing of Live MIDI clips. There are two Live devices:

- **LiveScore.Viewer** which displays, for each individual track, the content of a selected MIDI clip in standard music notation, and
- **LiveScore.Editor** which is the actual music editor. The LiveScore.Editor device has a graphical user interface that offers a number of convenient tools; among them: intelligent transcription with key and clef finder, a percussion map, a set of menus and palettes for easy navigation and interactive editing as well as microtonal notation and playback via the LiveScore sampler.

The MaxScore installer installs the free Aloisen New and Accidental music fonts into the Windows/Max OS X font folders. Also see Download page for further instructions as to how to obtain and install a JMSL license.

We are going to walk you through the first steps of using LiveScore. Let’s start by opening the Live Set named LiveScore Demo.als which you’ll find in `~/Library/Application Support/Ableton/Library/Sets/LiveScore` (Mac OS X) or `C:\Documents and Settings\your user name\My Documents\Ableton\Library\Sets\LiveScore` (Windows). This may take a while.

Live Score Viewer

You just opened a pretty cheesy arrangement of What a Wonderful World. In Live Session View click on the track called 3-Keys-Acoustic-Piano. If everything went fine, you should be able to see the transcription of the piano accompaniment. The piece is in F major, so choose the proper key signature from the Key Signature menu. You might find that it’s easier to read the line in bass clef, so select bass from the Clef menu. There are also a few quantization options ranging from quarter note-triplets to 32nd notes. In most cases, the default setting will yield a good enough result. Now, grab the scroll bar and scroll through the entire line. If you check the Auto Scroll button, the clip viewer will scroll and flash its notes automatically when you play back the piece.

The clip viewer updates its content dynamically, whenever you...
- switch to a different clip in the same track
- add or change notes in Live’s Clip View manually or by
- recording a new clip in Session View

Now we are ready to change a few notes in the ELEC.PIANO clip. First let’s switch to Live’s Clip View with shift-tab. Grab the first note and move it up an octave. When you go back to LiveScore, you’ll notice that the change you made is reflected in the score. If you copy the first three notes and paste them at the beginning of sequence, those notes also immediately appear in the score.

Let’s record a few new notes to a new clip. Right-click or ctrl-click on the track named “8 Kit-606 Classic-1” and choose Insert MIDI Track from the pop-up menu. You should see a new track called “9 MIDI.” Copy LiveScore.Viewer for instance by alt-dragging the device from another track onto the newly created track and right-click or ctrl-click on the first clip slot to insert a MIDI clip. You should see an empty MIDI clip which we’ll name FUN-WITH-SCORES. Just type cmd-R and enter the new name. Double-click on the MIDI clip to open the MIDI Note Editor, set loop length to a reasonable length, arm the track in the clip’s Mixer Section and start recording by clicking into the small triangle next to the clip name. Now use the computer keyboard or an external controller to record music. During recording you can switch to LiveScore.Viewer and watch the notes being transcribed automatically. Once you’re done recording, you can quantize the music in the Live MIDI Note Editor. The quantize option in LiveScore.Viewer is for display purposes only and doesn’t affect the timing of the notes!!

One thing that can’t be done in LiveScore Viewer is editing. This is where the LiveScore Editor comes in handy. Clicking on the Open Editor button will take you now to the editor and its Staff Manager which lets you select the clips you want to include in your score.

**Live Score Editor**

**New Score**

In order to edit a clip you’ll need to create a score first. This way, you’ll also be able to see the music of more than one clip at once and keep working with a rich score which may contain more expressions than the original Live clip (see known issues for potential caveats).

To create a new score choose New Score from the File menu.
This will create a score with a single measure and open the Staff Manager by pressing caps or choosing Staff Manager from the Edit menu.

Now let's choose “1 0 MELODY” from the Live Clip pop up menu and choose Transcribe Staff from the Edit menu. (The numbers in front of the Live clip names refer to their position in the clip matrix, the first number being track number, the second being scene number; numbering always starts with 0.)

In an instance, the Live clip will be transcribed and appear in the first staff. Press caps again to view the score. Let's add another staff to the score by choosing Insert Staff from the Edit menu.
This time we’ll assign “7 0 DRUMS” to the second staff. (Notice how the color of the Live Clip menu item reflects the colors assigned in the Live clip matrix.)

Unpitched percussion instruments such as bass drum or cymbal are usually notated with a special clef and a variety of noteheads which can be assigned and edited in the Percussion Map editor (the editor can be opened from the Edit menu). Now select Transcribe Staff from the Edit menu and, in the Staff Manager, choose the percussion clef on the bottom of the Clef pop-up menu after you’re done with transcription. The second staff should now fill with notes and shapes assigned to “Bass Drum 1,” “Side Stick” and “Closed Hi-Hat.”
Staff Manager

Transcription

You can switch to the Staff Manager by pressing the caps lock key, but you can also open it from the Edit menu. Let's now take a closer look at the Staff Manager. There are red buttons beneath the Transcription, Clef and Key Signature labels. When the Transcription button is turned off, the corresponding clip(s) will be excluded from transcription. This feature is very useful in case you want to add a staff after you've already embellished a staff previously. The other two buttons next to the Clef and Key Signature menus toggle automatic clef and key signature assignment by gauging the distribution of notes in a clip. When percussion clef is selected, automatic assignment is off, even though the corresponding button is still red. Clefs and key signatures can always be selected manually after transcription.

Transposition

In case of guitar or double bass, the instruments sound an octave lower than written. Therefore, you want to set transposition to 12 (semitones) after transcription.

Sorting

Besides layout and scoring options (Spacing Above and Below as well as Staff Lines and Ledger Lines), the Staff Manager also offers the possibility to rearrange staves. For this, enter the target staff numbers into the Staff number box and click on Sort.
Updating

If a MIDI clip is inserted or deleted from a Live clip slot, the Live Clips menu needs to be updated. Click on the underlined “Live Clips:” label to update the menu items.

Quantization

The result of transcription depends a great deal on the quantization settings. There are two places to set quantization, one in Live, the other in the MasterScore. For successful transcription it is crucial that the correct quantization has been set in Live first. For this, right-click (Win) or ctrl-click (Mac) on the piano roll grid on Live’s Clip View and make the appropriate choices.

Then experiment with MasterScore’s quantization settings. Choose Preference from the File Menu and click on the Quantization menu.
The default setting offers a mix of n-tuplets including quintuplets and septuplets. If you prefer simpler results, choose from the remaining quantization options: 4nt, 8n, 8nt, 16n, 16nt, 32n (with n meaning note and t meaning triplet).

**Playback**

MasterScore is sync’ed to Live’s transport, i.e. when you start playback, notes will flash and pages will turn automatically. You can turn this off by unselecting the corresponding items from the Playback Settings menu. You can also use LiveScore’s own playback engine which offers several playback modes to be selected from the Playback menu. This is particularly useful if your score contains microtones (Live itself doesn’t have microtonal playback capabilities).
Note that LiveSore Editor only transcribes a clip once. This can lead to problems when clips of varying lengths are looping in playback. There are several options to deal with this:

- Either make loop lengths equal in Live’s Clip View,
- play clips once by turning Loop off in Clip View or
- “spell out” the loop in the actual clip.
- Recreate the loops in the LiveSore Editor and use its playback.

A future version of the editor will introduce Loop Transcribe.

Now we’re ready to edit our score. Duplicate the track “2 Lead-Square” and delete the MIDI clip. Click on the first slot and press cmd-shift-M to create an empty MIDI clip. Press cmd-R and name the clip MELODY2. Click inside the first track and switch to track view. Open the score editor, create a new score, update the Live clip menu by clicking on the underlined “Live Clip:” label, insert a staff and transcribe clips “1 0 MELODY” and “2 0 MELODY2” to the first two staves. The first staff should be empty, the second should contain the melody to What a Wonderful World. Copy and freeflowpaste the first 8 notes to the second staff so that we create an imitation by a half note (see below). The new clip will automatically be updated as you add new notes to it, provided that Automatic Update is turned on in Preferences menu (it’s turned off by default because frequent updating of large scores can add a bit of overhead).

Note: You’ll need to click on first note of the selection and on last note of the selection with the shift key held (don’t try to shift-drag-enclose the notes). Choose fill empty measures with rests from the Scorepions menu and start embellishing the music by assigning dynamics, slurs, wedges and marks. Don’t forget to save your work as a separate file, as it won’t be included in the Live set.
Save/load/import a score

It’s time to save your work. Choose Save Score from the File menu and save the score to your favorite folder. When you reopen the file by choosing Load File from the File menu, the corresponding Live clips will be automatically assigned to their staves and you’ll be able to continue working on the score in sync with Live provided that you haven’t changed the MIDI clips in the meantime. If the score hasn’t been created with the Editor or you’re importing a MIDI file into Editor (we recommend importing MIDI files directly to the Live clip matrix), the staves have to be assigned manually to the Live clip matrix. Choose the clips from the Live Clip menu and click on update. Now the clips contain the notes from the score you’ve just loaded or imported and are perfectly in sync as long as the tempos match. (You can set master tempo in Live in the upper left-hand corner.)
Overview

Introduction

LiveScore Editor and MaxScore Editor are full-blown notation programs built with MaxScore—a Max Java object based on JMSL (the Java Music Specification Language) developed by Nick Didkovsky and Phil Burk. Both editors sport the same interface. The advantage of using MaxScore in comparison to other professional notation environments is its integration into the Max/MSP environment, allowing Max programmers to adapt the application to their needs. In addition, it can be fully controlled with Max messages while its output can be used by sound-generating patches for polyphonic, multi-timbral and microtonal playback. The MaxScore installer also installs a sampler which performs the aforementioned functions.

To start the LiveScore Demo Set open Sets\LiveScore\Livescore Demo.als or Sets/LiveScore/Livescore Demo.als inside the Ableton Live Library folder, on Windows or Mac OS X, resp. Refer to http://www.computermusicnotation.com/?page_id=659 as to how to locate the Ableton Live Library folder.

To start the MaxScore Editor with the MaxScore Sampler choose maxscore.combo from File->New From Template on both platforms.

First Steps

Create a new score by choosing New Score from from the File menu. You will see a long measure in a single staff. Add notes by ctrl-clicking (Mac) or right-clicking (Windows). Open the floating palettes from the Tools menu and explore their functionality. In addition, there are a number of keyboards shortcuts which are summed up here:
Below you’ll find a detailed explanation of the tools and menu items.

Before you can play back the notes you entered, you’ll have to load a bank in the sampler. As the sampler uses a proprietary format, you need to either download a bank from http://www.georphajdu.de/computermusicnotation/wopre/?page_id=291 or create your own with the Bank Editor that comes with the Quintet.net network performance environment. To load a bank click on Select Bank File and then Load Sound Files. Wait until you see done! before proceeding.

Menus

File

Since most File menu items are self-explanatory, we will only elaborate the last two items:

Print
Editor will allow you to create pdfs of the entire score right out of the Live or Max/MSP environments. Choose Print from the File menu and make the appropriate settings in the pane on the right. Since the preview window on the left also employs another copy of the MaxScore, you can even make some layout modifications there. Printing is bare-bones at the moment. Margins and page numbers will be supported in a future version of the MasterScore. The pdfs consists of rasterized vector-graphics files in svg format which will be deleted after printing. If you want keep those files, check the toggle on the bottom and look for them in a folder in the same location as the saved pdf.

Preferences
The Editor will attempt to autosave the preferences when the application is being closed. If you want to work with different sets of preferences, you can also manually save and load them by clicking on the buttons on the bottom. Attribute List will bring up a separate window summarizing the attributes and their current values.

Edit
The Edit menu entries are also self-explanatory to a large degree. Let’s focus on the things that may be a little different from the usual experience with commercial notation programs.

A few words about MaxScore’s selection methods:

1. Note selection: To select a note, click or drag-enclose it, to select a range of notes, click the first and shift-click the last note or drag-enclose a group of notes. Selected notes will turn blue. Most operations such as copy and pasting are applied to note selections.

2. Measure selection: To select a single measure, click inside the empty space of measure, to select a range of measures click in the first measure and shift-click inside the last measure. Selected measures have light-blue staff lines. Measure and staff operations such as changing clef or time signatures require measures to be selected.

Undo and Redo only work under certain, limited circumstances. Save your work frequently to avoid loss of data. Pasting over measure boundaries is accomplished with Paste Free Flow. Note that MaxScore will not split large durations into smaller ones if a note doesn’t fit into a measure. In other word, when you paste-free-flow a whole note into a $\frac{3}{8}$ measure, the entire note will be placed into the measure no matter what, and its color will change to pink to indicate that the total duration has exceeded the number of beats in the meter. You will be required to fix the notes duration manually at this point.

Occasionally, before entering notes to a measure different from the one you’re just working on, you need to make it current, or in JMSL’s terms, you need to set the current measure/staff to the selected measure/staff. Choose “Make Current” from the menu; this is a bit like setting an (invisible) cursor to a different location. The other items refer to Editor’s interaction with the Live environment and have no meaning in the Max environment. This is also the reason why Transcribe Staff and Update are grayed out in the MaxScore Editor.

Use the StaffManager to change some attributes such as the inter-staff distances as well transposition, ledger line and staff line visibility. Changing the indexes, will also allow you to sort the staves.
The Percussion Map allows you to edit MIDI-note-to-percussion-note-and-shape definitions. Possible shapes are: Standard, X, Diamond, X-Diamond, Triangle and Inverted-Triangle. This map will be used when the percussion clef is chosen in the StaffManager.

Tools

The four floating palettes and the Picster graphics patch will be explained below.

Scorepions

The Scorpion menu is part of a plugin system that will allow you to dynamically load Max patches, extending the
functionality of the Editor. These Max patches can easily be created and moved to a particular folder within the MaxScore Lib hierarchy. Refer to this page for further information.

Picster

Picster is a graphic tool created to expand the core repertoire of articulations and other symbols provided by JMSL, the foundation of MaxScore and LiveScore Editor. Picster will let you create library elements that can be reused any time or individual elements that can be inserted directly into the score. When you create a group of graphical elements (a group can also consist of a single element), you should name it before attaching it to a note, measure or measure/staff. Since several groups can be attached, the group menu next to the Playback menu offers a convenient way to differentiate between groups.

Let’s start by choosing sfz from the Picster menu. In addition, we will also choose the Pedal-down symbol. Notice that the two signs are now superimposed, we now want to move the Pedal-down symbol below the sfz.

Ctrl-shift click (alt-shift on Windows) on the Picster element and move the red bounding rectangle to a different position. The note, staff or measure that the element is attached to will become automatically highlighted, in case you want to edit or remove it.
A separate manual for the Picster patch can be found [here](http://www.computermusicnotation.com/?page_id=349).

# Playback

Set playback preferences and modes in the Playback menu.

# Tools

In the Tools menu you find the following 5 items:

## Note Entry Tool

This tool contains icons for operations that effect note entries:

- Accidental preferences, note durations, dots, note/rest toggle, note, note head and stem visibility as well as stem direction options, n-tuplet settings, grace-note transforms and notehead shapes.

## Pitch tool

This tool contains icons for operations that effect transposition and enharmonic spelling. Note that Live doesn’t
support microtonal playback. Therefore, use LiveScore Editor's built-in playback modes.

Note Attribute Tool

This tool contains icons for operations that affect “secondary” note attributes:

Dynamics, ties, slurs, beaming and unbeamung, crescendo, decrescendo, ottava alta and ottava bassa and lyrics as well as marks.

Measure/Staff/Track Tool

This tool contains icons for measure, staff and track operations:

Appearance of barlines (single, double, period double or none), left and right repeats (which currently has no impact on playback), number of repeats, time signature, tempo, custom and default measure width and track number (the maximum track number is set to 2 by default) as well as key-signature and clef menus. Select measures to apply any operations.

Picster
A separate manual for the Picster patch can be found [here](http://www.computermusicnotation.com/?page_id=349).

User Chris Macor has described his own experiences using LiveScore in [this pdf document](http://www.computermusicnotation.com/?page_id=349). Highly recommended!
Scorepions

As of MaxScore v.0.2 we are introducing a plugin system called Scorepions which allows Max programmers to create patches to control the behavior of the MaxScore for Live MasterScore.

We will now discuss how to create a Scorepion based on the Scorepion Template patch which can be found in MaxScore Lib/Tutorial/Scorepions.

The Scorpion Template as it will be presented to the user.

The same Scorepion, expanded and in Edit mode.

Scorepions to be included in the Scorepion menu need to reside in MaxScore Lib/Scorepions. This Scorepion is based on “Fill Empty Measures with Rests” and serves as an annotated template.

Besides the core set of Max objects and messages, a Scorepion patch consists of user interface elements which
need to be added to Presentation. Three outlets are used to control the behavior of the patch.
1. All messages to the MaxScore object go out the first outlet. They include the 200+ messages defined in the
MaxScore dictionary.
2. Messages to parent patch. Currently, there are three messages controlling the behavior of MaxScore:
a. transcribe. This message will cause transcription of clips selected in the Saff Manager.
b. update. This message sends the (modified) MaxScore note list to Live.
c. newScore. This message resets the Staff Manager and creates a new score with one staff.
3. Messages to bcanvas. These messages control the behavior of the bcanvas abstraction which draws score
elements such as lines and characters. Supported messages are:
width, height, writeat, openwindow, floatwindow, window, offset, name, zoomfactor, flash, setScoreSize, active,
mouseover, iscanvas, scoreLayout, framearc, setZoom, linesegment, frgb, penmode, paintpoly, writepict, svg,
graphicsBuffer, fillRect, drawRect, RenderMessage, musicfont, textfont, StaffLine, LedgerLine, Slur, Tie,
TieOut, TieIn, cresc, decresc, barline, RepeatDots, stem as well the following glyphs (further documentation will
soon be available):

accent, acciacatura, al, ba, doubleflat, doublesharp, eighthflagdown, eighthflagup, eighthrest, fermata, flat,
forte, fortissimo, fortississimo, halfrest, harmonic, invertedmordant, mezzoforte, mezzopiano, mordant,
natural, noteheadblack, noteheadblackdiamond, noteheadblackinvertedtriangle, noteheadblacktriangle,
noteheadslash, noteheadwhite, noteheadwhitediamond, noteheadwhiteinvertedtriangle, noteheadwhitetriangle,
noteheadwhole, noteheadx, noteheadxdiamond, noteheadxoval, ottavaalta, ottavabassa, pianissimo,
pianississimo, piano, pr, quarterrest, sharp, staccato, staccato_tenuto_down, te, tempoqtrequals, tenuto,
timesigo, timesig1, timesig2, timesig3, timesig4, timesig5, timesig6, timesig7, timesig8, timesig9, tr, tremolo1,
tremolo2, tremolo3, trill, tupeto, tuplet1, tuplet2, tuplet3, tuplet4, tuplet5, tuplet6, tuplet7, tuplet8, tuplet9,
wedgedown, wedgeup, wholerest
Microtones

The MaxScore and LiveScore Editors were designed with microtones in mind with the capability of representing pitch with unlimited precision. The editor offers notation in quarter-tone, eighth-tone and 12th-tone resolutions (the latter with two different sets of accidentals) as well the Extended Helmholtz-Ellis JI Pitch Notation, and cent precision playback via MaxScore Sampler or MaxScore Fluidsynth. Pitch Tool’s floating palette will let you transpose pitch by cent increments and/or just ratios. Each note can also be labelled either according to its pitch, frequency or ratio in respect to given fundamental. There is a potentially unlimited number of “keyboards” which will let you choose a tuning and allow convenient entry of its pitch sets.

Notation of an ascending sequence of notes in 72TET with quarter-tone resolution and MIDI Cent labels

Notation with eigth-tone resolution and MIDI Cent labels

Notation with 12th-tone resolution and MIDI Cent labels (extended 6th-tone notation à la Manfred Stahnke)
Notation with 12th-tone resolution and MIDI Cent labels (using Ezra Sims’ notational system)

Same notation as above with Hz labels.

43-tone Partch scale in Extended Helmholtz-Ellis JI Pitch Notation with ratio labels.
MaxScore for Max/MSP and Ableton Live
Music Notation for Max/MSP and Ableton Live

Playback

MaxScore/LiveScore Sampler and MaxScore/LiveScore Fluidsynth are two playback patches/devices that were especially designed for the MaxScore/LiveScore Editor and its microtonal capabilities. So far, the combination of Editor and Sampler and/or Fluidsynth is the only way to consistently compose and playback microtonal music in Ableton Live and, therefore, relies on a different communication protocol from MIDI.

Fluidsynth und Sound Fonts

The fluidsynth player is capable of using an abundance of sound fonts available on the Net.

Download default sound font.

Sampler and Sample Banks

The sampler uses a propriety text-based format and depends on the Quintet.net Bank Editor for the fast generation of new sound banks.
The editor is part of the Quintet.net release.

Virtual Orchestra Collection (© Thomas Hummel):

Piano.zip 130 MB (a large collection of high-quality grand piano sounds sampled with and without pedal down)

We will post new MaxScore sample banks here, as they become available.
Picster

Picster is an independent Max patch for the creation of graphical content that has been thoroughly integrated into MaxScore. It works like a bare-bones paint program and was authored by Jacob Sello and Georg Hajdu.
Creating graphical elements

Choose a shape from the shape menu and use the mouse to draw it at the desired location on the canvas.
Available shapes are:

linesegment, framerect, paintrect, frameoval, paintoval, frameroundrect, paintroundrect, framearc, paintarc, framepoly, paintpoly, freehand, text, picture.

After placing an element click on Color: and choose a color from the color picker. Adjust its transparency with the transparency slider.

Text entry

Choose the large A from the menu and place the cursor anywhere on the canvas. Start typing and complete your entry with the return key. Currently, you can’t place the cursor inside the text for immediate correction. Read below to find out how change text attributes.

Creating a special text element

There are a number of fonts that contain of graphical score elements such as the MidiDesign Free fonts by Christian Texier. In order to use them in Picster, you’ll need to know their unicode code point which is usually
written as U+ followed a hexadecimal number. To identify this code, use Font Book on the Mac or a font utilities such as MainType on Windows. In Font Book, choose a font and hover over a character to display its unicode code point such as U+2020. Back in Picster, choose the text tool and start typing the string ideally in the upper left hand corner, so that the offset is not too large when attaching the element to a note in the MaxScore/LiveScore Editor. It is recommended that you set the font after placing the text element.

Placing and manipulating images

Select the tool from the bottom of the shapes menu and use the tools above to place, move, resize and crop the image.

Editing elements

Select the move button and click on any of the elements on the canvas. When selected, its outline should be red. Move the element to a new place or edit its attributes in the Attributes List. Certain attributes such as roundedness of corners can only be set in the Attributes List. In case of text, corrections can only be made in the attributes window.

Saving and opening library items

While Picster elements can be directly attached in the MaxScore editor to note, staves and measures it is wise to create library elements that can be used repeatedly after saving it to the Picster Library folder. For this, click and on the disk icon and either re-name the element or use the name you have previously entered in the group name field. In the MaxScore editor the Library item will be displayed after manually refreshing the contend of the menu. Accordingly, groups can also be opened (click on the folder icon) for further editing.

Attaching groups to MaxScore elements

Once your done creating and editing your graphics, the group of objects can be attached to a note, a measure/staff or a measure. Give your group a name before proceeding with the next step. In the Picster menu of the MaxScore Editor choose Attach. Now the group should appear in the score. You can position the element by entering appropriate values in the offset number boxes next to the Playback menu. You can find further information on the MaxScore Editor Picster menu here.

Editing groups

A group that has been attached to a MaxScore element can be edited. The section on Picster in the MaxScore Editor Overview explains how to select a group and make it available for editing.

Known issues

Picster is still in an early development stage. There are a number of know issues:
1. Delete key. Some versions of the Max live.menu (the menu that lets you choose the shapes) use the delete key to set the menu to its beginning. In order to avoid unexpected results, unselect the menu by clicking in the area outside of it after making your choice.

2. Currently, it is not possible to unselect a Picster item once it has been created. Therefore, make your choices of font, pen size and color after the object was created, otherwise the previously created object will be affected.

3. Color picking is not quite as reliable as it should be.

4. Occasionally, the cursor stays on, even after choosing a different tool from the text tool.

5. New elements have a red outline which could mislead users into believing that they can move the element around. For this, the mover tool needs to be selected first though.

6. Currently there is no support for cut, copy and paste. We're working on it.

MaxScore for Max/MSP and Ableton Live
Proudly powered by WordPress.
Ableton Live Library Location

Determining the location of your Ableton Live folder on Mac OS X:

In Ableton Live open the Library pane of the Preferences window and control click on the path shown on top of the pane.

This will give you an option to see the location in the Finder:
Click on any of the enclosed folders and press ctrl-I:
In General next to “Where:” you can now select the Ableton Library path and copy it to the clipboard.

Determining the location of your Ableton Live folder on Windows:

In Ableton Live open the Library pane of the Preferences window and right click on the path shown on top of the pane:

![Screenshot of Ableton Live Preferences window](image)

This will give you an option to see the location in the Explorer:

![Screenshot of Explorer window](image)

Right click on the path shown on top of the Explorer window and copy it as text to the clipboard.
Macaque

Macaque is an application for conversion of SDIF files (generated by applications such as SPEAR or AudioSculpt) into sheet music. You'll find the current version in a folder called Macaque in your Max5 patches folder.

Macaque is using MaxScore to generate and display the following scores:

1. 32-voice transcription of sinusoidal tracks
2. Display of the harmonic content of a selected frame (partials with relative dynamics and cent deviation)
3. Rhythm and pitch detection via segmentation of the sum-of-amplitude curve (modes are rhythm, fundamental, lowest pitch, salient pitch, centroid, centroid nearest neighbor, and chord). For segmentation, you can set markers manually, automatically or import them from AudioSculpt.

The processed scores can be played simultaneously with the original SDIF file as well as copied and pasted into other MaxScore files an/or exported to MusicXML for further post-processing in Finale or Sibelius.

A graphical function editor allows the time-dependent manipulation of various parameters such as amplitude, temporal trajectory, spectral stretching and transposition.

Transcribed rhythm with median pitches
Transcribed sinusoidal tracks

**Macaque** requires installation of

- Jasch objects
- ejies
- CNMAT-Everything
- zsa.descriptors

Proudly powered by WordPress.
Known Issues

General issues:

1. Creating grace notes will break slurs, ties, crescendo/decrescendo wedges as well as ottava alta/bassa lines.
2. Overlap of score expressions. MaxScore is based on JMSL which was designed to give composers a tool for real-time composition and notation. Due to speed concerns, proper positioning of score expressions has had lower priority. Use Picster to create elements with greater control of placing.

Live Issues:

1. Notes in Live clips have only five dimensions (Pitch, Time, Duration, Velocity, Muted) MaxScore has 22. Therefore, re-transcribing will erase previous edits. By changing the Muted dimension from boolean to double or by introducing extra custom dimensions, Ableton would greatly improve two-way compatibility between Live and LiveScore.
2. Don’t attempt to close any non-Live windows with cmd-W as this will only affect Live’s main window. You can’t avoid using the mouse.

MaxScore/LiveScore Editor Issues:

1. Grace notes are currently disabled.
FAQ

Basic Questions

How do I enter music with the mouse?

- Add a note: ctrl-click (Mac) or right-click (Windows)
- Transpose note manually: cmd-drag (Mac) or ctrl-drag (Windows)
- Use cut (x), copy (c) and paste (v) to move or copy music from one location in the score to another.

How do I select notes?

- Drag-enclose the notes with the mouse
- Click on a note and and shift-click on a second note. All notes in-between will now be selected.

How do I select a measure/range of measure?

Click into an empty space within a measure. Its staff lines should be drawn in light-blue. If you hold down the shift key and you click into an empty space within different measure, a range of measures will now be selected and highlighted.

When adding new notes they end up in the wrong measure. How do I go back to a previous measure?

Select the measure you want to add the notes to and press “s” or choose “Make Current” from the Edit menu. You should now be able to add notes to the selected measure.

When open the editor and start entering music, I see strange characters instead of music glyphs. What gives?

You probably have a non-installed font preselected. Choose Aloisen New in the MaxScore / LiveScore Preferences as it has been already automatically installed onto your system when you ran the installer.

What is the difference between a measure, a staff and a measure/staff?

Think of measure and staves as two-dimensional matrix with staves as the x axis and measures as the y axis. A measure refers to vertical content across all staves for a given measure number, whereas staff refers to horizontal content across all measures for a given staff number. A measure/staff refers to the cross-section between a given measure and staff. This is the smallest unit in the matrix, so to speak.

What is the easiest way in MaxScore to set the tempo to something other than a quarter note?
This is requires hiding MaxScore's own tempo markings and creating "graphical" markings with the addRenderedMessageToMeasure message. You will find a demo of an abstraction that implements this functionality in the Cycling '74/MaxScore Lib/Examples/mySetTempo folder.

I tried to open a score, but all I see is an empty documentation window

Don’t forget, MaxScore sits inside the Max/MSP environment with its own set of menus. What you have probably done is to try to open the score from the host not from within the MaxScore editor. Try to open the file from the editor's own File menu (which, Windows-style, sits right under the title bar) by choosing Load Score.

Are there differences between the Max 5 and Max 6 versions?

Yes, a very small one affecting the selection of Picster items: MaxScore for Max 6 uses a method that more reliably determines the enclosing rectangle for text items.

Ableton Live

In Live, how do I record music into a clip after it was transcribed and embellished:

If you have already edited a staff but want to record more music into the associated clip, we recommend you insert another staff, assign it to the same clip, transcribe the music and copy the additional notes into the old staff. You can now safely remove the new staff.

What happens if I add a new Live clip and want to transcribe it too?

If you add a clip and you can't find it in the Staff Manager's Live Clip menu, click on the underlined "Live Clip:" label to update the menu.

In Live, what do I have to consider when adding notes to a percussion staff?

When adding notes to a percussion staff, you need to update the percussion notehead assignment by selecting the staff in question and choosing "Check percussion notehead assignment" from the Scorepions menu.

Microtonality

When transferring a microtonal score from MaxScore to Sibelius (or Finale) via XML, will the microtonal notation (accidentals) stay as written? That is, will each note and accidental stay precisely the same?

Not really, Finale can import and display quarter tones, but transposing and editing leads to unexpected results. According to reports found online, Sibelius is also able of importing quarter-tone notation. To my knowledge, the only notation editor capable of importing microtonal music in eighth-tone resolution is Noteability Pro.

Yet, since MusicXML doesn't specify the font and appearance of the microtonal accidentals to be used, there is no guarantee that they will end up looking like they did in MaxScore.
Version History

0.3 (to be released in December 2011)

- New messages and bug fixes for the core MaxScore object
- MaxScore for Live MasterScore renamed to LiveScore Editor
- MaxScore for Live ClipView renamed to LiveScore Viewer
- Created MaxScore Editor as well as MaxScore Sampler and MaxScore Fluidsynth microtonal playback engines
- Countless improvements to the Editor interface
- Created the Picster graphics editor as well as a library for symbols extending JMSL’s native set of symbols.
- Included Macaque, a spectral transcription and processing application

0.2 (released on May 23, 2011)

- Created the Scorepion plugin system for control of MasterScore via custom Max patches
- Switched to faster xml parsing
- Added subtitle, title margin, setTitleVisible
- Added support for music and text fonts
- Add “select all notes in measure/staff” in Select Special...

0.1 (released on April 20, 2011)

- Release of MaxScore for Live